0%

解决将 ionic2 升级至 3 时出现的 webpackJsonp 问题

ionic3 修复了2.x 存在的 ion-select 组件的 interface 等 bug,因此对其进行升级。修改 package.json,删除 node_module 目录,在 npm I 的时候依次按照提示在 package.json 中将不符合版本的库改为兼容版本。

升级完成之后 build 时提示 webpackjsonp is not defined,翻阅 README 的 Change log 发现新版 cli 脚手架写的 webpack 配置有所改变,将公用部分使用 CommonsChunkPlugin 额外打了一个包,此包命名为 vendor。在 app 入口文件中引用该公用包解决问题。